source: flair-src/trunk/demos/MixedReality/virtual/simulator/CMakeLists.txt@ 380

Last change on this file since 380 was 365, checked in by Sanahuja Guillaume, 2 years ago

change simu apps compilation to avoid problem with mixing host and toolchain libs
(log2@glibc_2.29 error when compiling on ubuntu 20.05 or mint 20)
now compile with host g++ and libs (except filelib, irrlicht, quat, udt and vrpn) for simu apps using the macro: FLAIR_DEMO_HOST_CXX

File size: 781 bytes
Line 
1PROJECT(MixedReality_simulator_virtual)
2cmake_minimum_required(VERSION 2.8)
3
4SET(FLAIR_USE_SIMULATOR TRUE)
5SET(FLAIR_USE_SIMULATOR_GL TRUE)
6SET(FLAIR_USE_SENSOR_ACTUATOR TRUE)
7
8include($ENV{FLAIR_ROOT}/flair-src/cmake-modules/GlobalCmakeFlair.cmake)
9
10if("${CMAKE_SYSTEM_PROCESSOR_DEFAULTTUNE}" MATCHES "core2-64")
11
12SET(SRC_FILES
13 src/main.cpp
14)
15
16FLAIR_DEMO_HOST_CXX(${PROJECT_NAME} "${SRC_FILES}"
17 DEST_DIR MixedReality_virtual
18 COPY_RESOURCES
19)
20
21else()
22 if(DEFINED CMAKE_SYSTEM_PROCESSOR_DEFAULTTUNE)
23 warn("${PROJECT_NAME} will not be built for ${CMAKE_SYSTEM_PROCESSOR_DEFAULTTUNE} architecture")
24 else()
25 warn("${PROJECT_NAME} will not be built for ${CMAKE_SYSTEM_PROCESSOR} architecture")
26 endif()
27endif()
Note: See TracBrowser for help on using the repository browser.