Ignore:
Timestamp:
10/05/20 09:32:31 (16 months ago)
Author:
Sanahuja Guillaume
Message:

change simu apps compilation to avoid problem with mixing host and toolchain libs
(log2@glibc_2.29 error when compiling on ubuntu 20.05 or mint 20)
now compile with host g++ and libs (except filelib, irrlicht, quat, udt and vrpn) for simu apps using the macro: FLAIR_DEMO_HOST_CXX

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/scripts/distribution_specific_hack.sh

    r360 r365  
    2626fi
    2727
    28 if [ _$DISTRIB_ID = _Ubuntu ]; then
     28#also needed in mint, but for different reason?
     29#if not in sudo in mint, simlator does not work cause of:
     30#libGL: MESA-LOADER: failed to open /usr/lib/x86_64-linux-gnu/dri/iris_dri.so: /usr/lib/x86_64-linux-gnu/dri/iris_dri.so: failed to map segment from shared object
     31
     32#if [ _$DISTRIB_ID = _Ubuntu ]; then
    2933  #tested on Ubuntu 17.10
    3034  #we must run as root
     
    3842  fi
    3943
    40 fi
     44#fi
    4145
    4246#special actions if we use 3D
Note: See TracChangeset for help on using the changeset viewer.