source: flair-src/trunk/scripts/distribution_specific_hack.sh @ 360

Last change on this file since 360 was 360, checked in by Sanahuja Guillaume, 5 months ago

diusable dri3 if used

File size: 2.9 KB
Line 
1#check required version of a lib in host graphic lib (ie i965)
2#return 1 if robomap3 version is not sufficient
3function check_required_lib_ver () {
4    DRIVER_LIB=$1       
5    PATTERN=$2
6    LIB=$3
7
8    #get the highest required version of $PATTERN
9    VER_REQUIRED=$(objdump -T $DRIVER_LIB | grep $PATTERN | sed -e 's/.*'$PATTERN'_\(.*\) .*/\1/' | sort -uV | tail -1)
10    #get currently used $LIB
11    LIB_PROVIDED=$(ldd $EXEC | grep $LIB | sed -e 's/.*=> \(.*\) (.*/\1/')
12    #get the highest version of $PATTERN supported by the $LIB
13    VER_PROVIDED=$(objdump -T $LIB_PROVIDED | grep ".*"$PATTERN"_[0-9.]*$" | sed -e 's/.*'$PATTERN'_\(.*\)/\1/' | sort -V | tail -1)
14    if [ $(echo -e "$VER_PROVIDED\n$VER_REQUIRED" | sort -V | tail -n1) != $VER_PROVIDED ]; then
15        echo "We must use the local system $LIB"
16        return 1
17    fi
18}
19
20function green_echo () {
21        echo -e "\033[32m$1\033[0m"
22}
23
24if [ -f /etc/lsb-release ]; then
25  . /etc/lsb-release
26fi
27
28if [ _$DISTRIB_ID = _Ubuntu ]; then
29  #tested on Ubuntu 17.10
30  #we must run as root
31  if [ $EUID -ne 0 ]; then
32    exec sudo -E $0 $*
33  fi
34
35  #we must run in root cgroup to escape possible restrictions on scheduling
36  if [ -d /sys/fs/cgroup/cpu ]; then
37    echo $$ > /sys/fs/cgroup/cpu/tasks
38  fi
39
40fi
41
42#special actions if we use 3D
43ldd $EXEC | grep "libGL.so" > /dev/null
44if [ $? -eq 0 ]; then
45    green_echo "checking for incompatibility when using libGL and trying to solve it..."
46    #allow root access to the X server
47    xhost si:localuser:root
48
49    #Mesa DRI driver may need a lib more recent than robomap3's
50    ldconfig -p | grep mesa > /dev/null
51    if [ $? -eq 0 ]; then
52        read DRI_CARD_MAJOR DRI_CARD_MINOR < <(stat -c '%t %T' /dev/dri/card0)
53        DRIVER=$(cat /sys/dev/char/$((16#$DRI_CARD_MAJOR)):$((16#$DRI_CARD_MINOR))/device/uevent | grep DRIVER | cut -d= -f2)
54        echo "Mesa DRI driver is $DRIVER"
55        DRIVER_LIB=$(LIBGL_DEBUG=verbose glxinfo 2>&1 | grep "\.so" | tail -n 1 | grep -o '/.*\.so')
56
57        #todo: make a list, find a complete one!
58        check_required_lib_ver $DRIVER_LIB GLIBC libm.so.6
59        if [ "$?" = "1" ]; then
60                   ADDED_LIBS=$(ldconfig -p | grep libm.so.6 | grep libc6,x86-64 | cut -d'>' -f2)
61            fi
62
63        check_required_lib_ver $DRIVER_LIB CXXABI libstdc++.so.6
64        if [ "$?" = "1" ]; then
65                   ADDED_LIBS="$ADDED_LIBS:$(ldconfig -p | grep libstdc++.so.6 | grep libc6,x86-64 | cut -d'>' -f2)"
66            fi
67
68        #remove whitespace
69        #add libs to LD_PRELOAD if version robomap3 version is not sufficient
70        export LD_PRELOAD="$(echo -e "${ADDED_LIBS}" | tr -d '[:space:]')"
71    fi
72
73    #check if using DRI3 and disable it
74    #otherwise you get /usr/lib/x86_64-linux-gnu/libGLX_mesa.so.0: undefined symbol: xcb_dri3_get_supported_modifiers
75    cat /var/log/Xorg.0.log | grep DRI3 > /dev/null
76    if [ $? -eq 0 ]; then
77        export LIBGL_DRI3_DISABLE=1
78        echo "we must disable DRI3"
79    fi
80    green_echo "...done\n"
81fi
82
83
84
Note: See TracBrowser for help on using the repository browser.