Changeset 365 in flair-src for trunk/lib


Ignore:
Timestamp:
Oct 5, 2020, 9:32:31 AM (14 months ago)
Author:
Sanahuja Guillaume
Message:

change simu apps compilation to avoid problem with mixing host and toolchain libs
(log2@glibc_2.29 error when compiling on ubuntu 20.05 or mint 20)
now compile with host g++ and libs (except filelib, irrlicht, quat, udt and vrpn) for simu apps using the macro: FLAIR_DEMO_HOST_CXX

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/lib/FlairSimulator/src/Gui_impl.cpp

    r294 r365  
    8585  this->scene_height = scene_height;
    8686
    87   device = createDevice(driver_type, dimension2d<u32>(app_width, app_height),
    88                         16, false, false, false);
     87  device = createDevice(driver_type, dimension2d<u32>(app_width, app_height),16, false, false, false);
     88  if(device==NULL) self->Err("Irrlicht failed to create video device\n");
    8989  receiver = new MyEventReceiver();
    9090  device->setEventReceiver(receiver);
Note: See TracChangeset for help on using the changeset viewer.