wiki:repo/sync_old

Version 3 (modified by Bayard Gildas, 2 years ago) (diff)

--

Get repositories

Depending on what you are doing with Fl-AIR, there are several options for getting the repositories.

If you are an Heudiasyc user, you also need flair-hds repository, see here.

Only developing applications based on latest Fl-AIR version

To get the latest version of Fl-AIR run the following commands:

$ cd $FLAIR_ROOT
$ svn co https://devel.hds.utc.fr/svn/flair-dev/tags/latest flair-dev
$ svn co https://devel.hds.utc.fr/svn/flair-bin/tags/latest flair-bin
$ svn co https://devel.hds.utc.fr/svn/flair-src/tags/latest flair-src

Developing applications based on multiple versions of Fl-AIR

If you need more than one version of Fl-AIR on your computer, on solution is to do the following:

$ cd $FLAIR_ROOT
$ svn co https://devel.hds.utc.fr/svn/flair-dev flair-dev_svn
$ svn co https://devel.hds.utc.fr/svn/flair-bin flair-bin_svn
$ svn co https://devel.hds.utc.fr/svn/flair-src flair-src_svn

This will sync all the repositories. To avoid this have look at --set-depth svn command.

Then make a symbolic link to the version you need:

$ cd $FLAIR_ROOT
$ ln -s flair-dev_svn/tags/0.0.1 flair-dev
$ ln -s flair-bin_svn/tags/0.0.1 flair-bin
$ ln -s flair-src_svn/tags/0.0.1 flair-src

Developing on Fl-AIR

To develop on Fl-AIR (lib, tools or demos), you need the trunk. It can be also a good idea to have the tags.

$ cd $FLAIR_ROOT
$ svn co https://devel.hds.utc.fr/svn/flair-dev flair-dev_svn
$ svn co https://devel.hds.utc.fr/svn/flair-bin flair-bin_svn
$ svn co https://devel.hds.utc.fr/svn/flair-src flair-src_svn

This will sync all the repositories. To avoid this have look at --set-depth svn command. example, to only checkout the trunk:

Then make a symbolic link to the trunk:

$ cd $FLAIR_ROOT
$ ln -s flair-dev_svn/trunk flair-dev
$ ln -s flair-bin_svn/trunk flair-bin
$ ln -s flair-src_svn/trunk flair-src