Opened 5 years ago

Closed 3 years ago

#22 closed enhancement (invalid)

add timeout on sharedmem producer/consumer

Reported by: Sanahuja Guillaume Owned by: Bayard Gildas
Priority: major Milestone:
Component: core Version:
Keywords: Cc:

Description

there is no timeout for the moment
if we kill uav program and simulator is not launched, the uav program is blocked at reading a picture in the shared memory

Change History (5)

comment:1 Changed 4 years ago by Sanahuja Guillaume

the problem is in FlairCore?/src/SharedMem_impl.cpp line 222 to 226
read is blocking

comment:2 Changed 4 years ago by Bayard Gildas

I don't get the exact problem: is there a point launching the uav program with no simulator? Actually I tried to start the GCS and then launch the uav: it doesn't block... but it crashes

comment:3 Changed 4 years ago by Sanahuja Guillaume

the crash comes from:
https://devel.hds.utc.fr/software/flair/ticket/36#comment:5

yes you can launch uav without simulator if you want to check your program without flying; for exemple:
-check if the gui is good (if you add new things, etc)
-debug connection between gcs and uav

comment:4 Changed 3 years ago by Bayard Gildas

After resolution of bug #36, this one vanished.

comment:5 Changed 3 years ago by Bayard Gildas

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.